Repositories

grarr

(mirrored on github)

Wim Looman <wim@nemo157.com>
bfafda Fix duplicate libgit2-sys versions
Wim Looman committed at 2016-05-16 14:04:00

Modified Cargo.lock

@@ -5,7 +5,7 @@ dependencies = [
"chrono 0.2.22 (registry+https://github.com/rust-lang/crates.io-index)",
"clippy 0.0.64 (registry+https://github.com/rust-lang/crates.io-index)",
"git-appraise 0.2.0 (registry+https://github.com/rust-lang/crates.io-index)",
"git2 0.4.3 (git+https://github.com/Nemo157/git2-rs?rev=packbuilder)",
"git2 0.4.3 (registry+https://github.com/rust-lang/crates.io-index)",
"gravatar 0.1.4 (registry+https://github.com/rust-lang/crates.io-index)",
"hyper 0.8.1 (registry+https://github.com/rust-lang/crates.io-index)",
"iron 0.3.0 (registry+https://github.com/rust-lang/crates.io-index)",
@@ -144,17 +144,6 @@ dependencies = [
[[package]]
name = "git2"
version = "0.4.3"
source = "git+https://github.com/Nemo157/git2-rs?rev=packbuilder#7d13d1595fb74afe9465e7b530e76f838a669ce0"
dependencies = [
"bitflags 0.1.1 (registry+https://github.com/rust-lang/crates.io-index)",
"libc 0.2.11 (registry+https://github.com/rust-lang/crates.io-index)",
"libgit2-sys 0.4.3 (git+https://github.com/Nemo157/git2-rs?rev=packbuilder)",
"url 1.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
]
[[package]]
name = "git2"
version = "0.4.3"
source = "registry+https://github.com/rust-lang/crates.io-index"
dependencies = [
"bitflags 0.1.1 (registry+https://github.com/rust-lang/crates.io-index)",
@@ -270,20 +259,6 @@ source = "registry+https://github.com/rust-lang/crates.io-index"
[[package]]
name = "libgit2-sys"
version = "0.4.3"
source = "git+https://github.com/Nemo157/git2-rs?rev=packbuilder#7d13d1595fb74afe9465e7b530e76f838a669ce0"
dependencies = [
"cmake 0.1.17 (registry+https://github.com/rust-lang/crates.io-index)",
"gcc 0.3.28 (registry+https://github.com/rust-lang/crates.io-index)",
"libc 0.2.11 (registry+https://github.com/rust-lang/crates.io-index)",
"libssh2-sys 0.1.37 (registry+https://github.com/rust-lang/crates.io-index)",
"libz-sys 1.0.3 (registry+https://github.com/rust-lang/crates.io-index)",
"openssl-sys 0.7.10 (registry+https://github.com/rust-lang/crates.io-index)",
"pkg-config 0.3.8 (registry+https://github.com/rust-lang/crates.io-index)",
]
[[package]]
name = "libgit2-sys"
version = "0.4.3"
source = "registry+https://github.com/rust-lang/crates.io-index"
dependencies = [
"cmake 0.1.17 (registry+https://github.com/rust-lang/crates.io-index)",

Modified Cargo.toml

@@ -13,7 +13,7 @@ maybe_cache = []
[dependencies]
git-appraise = "*"
git2 = { git = "https://github.com/Nemo157/git2-rs", rev = "packbuilder" }
git2 = "*"
hyper = "0.8.1"
iron = "*"